OpenLM Maintenance release version 1.8.1.43

OpenLM Server version 1.8.1.43 – maintenance release

OpenLM Server version 1.8.1.43 is a maintenance release to version 1.8. Please upgrade if you are monitoring the DSLS license manager.

What’s new in OpenLM Server 1.8.1.43 (May 09, 2014)

– 0001917: [OpenLM Server] DSLS reports parsing wrong. – resolved

How to upgrade?

Backup your OpenLM Database and install the new version on-top of your existing version. This upgrade does not include a database upgrade, only software.

 

OpenLM Maintenance Release Version 2.0.0.11

OpenLM Server version 2.0.0.11

OpenLM Server version 2.0.0.11 is a maintenance release to OpenLM version 2.0. It contains a bug fix to the firebird upgrade script (1.8 to 2.0 upgrade).

Only use or upgrade to this version if you can’t upgrade your 1.8 version to 2.0.

Upgrading the OpenLM Server

In order to upgrade to version 2.0.0.10:

1. Download the OpenLM Server installation file from the ‘Downloads’ section in the OpenLM site.

2. Stop the OpenLM Server service

3. Backup your DB file (Typically located in: C:\Program Files (x86)\OpenLM\OpenLM Server\db)

4. Make sure ALL windows are closed; especially the services window.

5. Install the new version on top of the existing one.

6. If prompted to do so, contact OpenLM to obtain an up-to-date license file. Please provide your MAC address and Hostname (case sensitive) for that. Copy this file to the

C:\Program Files (x86)\OpenLM\OpenLM Server\License   folder, and restart the OpenLM Server service.

 

OpenLM New and Last Pre-Release Version 2.0.0.7

OpenLM Pre-release version 2.0.0.7

Pre-release version 2.0.0.7 is planned to be the last pre-release version, it includes bug fixes and new functionality. Note that this is still a pre-release version not intended for production use, please don’t upgrade your production system.

 

Please check for upgrade instructions at the end of this message.

What’s new in OpenLM Pre-release Server 2.0.0.7 (May 28, 2014)

– 0001835: [EasyAdmin] Links In “License Servers” and “Feature Usage Status” should be disabled if the “CCL” and/or “Licenses” are not enabled  – resolved.

– 0001845: [OpenLM Server] OLM-Server – Notifications – Can not set up for public mail such as gmail  – resolved.

– 0001573: [OpenLM Server] PHP and lightpd services did not start  – resolved.

– 0001829: [General] PHP service will not start  – resolved.

– 0001740: [General] Read RMS debug log file.  – resolved.

– 0001787: [EasyAdmin] prompt the user before exiting when there are unsaved changes  – resolved.

– 0001837: [OpenLM Server] License usage – handle current sessions with candidate end time  – resolved.

– 0001329: [OpenLM Server] Link from licenses to license procurement  – resolved.

– 0001910: [OpenLM Server] License usage problem when feature is obsolete BUT the quantity is still open (due to errors)  – resolved.

– 0001889: [OpenLM Server] Cant install 2.0.0.6. Even when installing from scratch (not upgrade)  – resolved.

– 0001905: [EasyAdmin] License Servers  – resolved.

– 0000828: [OpenLM Server] Bad message in oracle based upgrade  – resolved.

– 0001902: [OpenLM Server] Problems showing mixed NMU/Floating license  – resolved.

– 0001898: [OpenLM Server] Can’t upgrade SQL DB 1.8 –> 2.0  – resolved.

– 0001792: [EasyAdmin] explanation is not clear in new alert condition “feature usage by period”  – resolved.

– 0001569: [EasyAdmin] add immediate help to complex option in EasyAdmin  – resolved.

– 0001579: [EasyAdmin] Option file admin window stuck.  – resolved.

– 0001854: [EasyAdmin] Options file selected, but won’t save.  – resolved.

– 0001853: [EasyAdmin] User settings – remove ‘Next’ button on last step of wizard  – resolved.

– 0001872: [EasyAdmin] Version Filtering does not work in “License Procurement”  – resolved.

– 0001788: [EasyAdmin] alerts add destination form is not clear  – resolved.

– 0001859: [OpenLM Server] Suspension not working with Autocad license.  – resolved.

– 0001828: [EasyAdmin] provide additional predefined filters  – resolved.

– 0001860: [EasyAdmin] selecting a date should move the active option to “expires before”  – resolved.

– 0001848: [EasyAdmin] Problem related to startup filters  – resolved.

– 0001592: [EasyAdmin] Error when saving option file – was not shown to the user  – resolved.

– 0001661: [OpenLM Server] Light: Must use “openlm remotely queries license manager” since broker is not included  – resolved.

– 0001878: [EasyAdmin] New icon is not visible  – resolved.

– 0001879: [EasyAdmin] can’t close alert rules window on firefox  – resolved.

– 0001821: [EasyAdmin] Alert Management – Destinations – Email field is required though users can be selected  – resolved.

– 0001822: [EasyAdmin] Alert Management – Destinations, when selecting “Defined by custom pattern” settings are set to zero  – resolved.

– 0001823: [EasyAdmin] Alerts Management – Destinations – SMS – “Adress” should be called “Phone number”  – resolved.

– 0001836: [EasyAdmin] Vendors and Features of deleted Servers for Unmanaged Processes show up in Filters  – resolved.

– 0001869: [OpenLM Server] Can not read information from the Options file.  – resolved.

– 0001849: [EasyAdmin] error removing unmanaged – during presentation  – resolved.

– 0001858: [EasyAdmin] Easy Admin – Email/SMS – Email: Email is not working  – resolved.

– 0001862: [EasyAdmin] Usage level should be rounded to integer  – resolved.

– 0001838: [EasyAdmin] Alerts configuration: Can’t add conditions  – resolved.

– 0001692: [OpenLM Server] fatal error  – resolved.

– 0001857: [OpenLM Server] Can’t close Autodesk session manually.  – resolved.

– 0001558: [EasyAdmin] negative up time to license server  – resolved.

– 0001880: [EasyAdmin] License Usage – The total line dissapers (development) – closed.

– 0001580: [EasyAdmin] adding user to role easyadmin hung up  – closed.

– 0001856: [OpenLM Server] KeyNotFoundExceptions in configuration form  – closed.

 

How to upgrade from previous versions

 

Upgrading from older versions using Firebird database

 

Upgrading an existing version is done by installing the new version on-top of the existing version. OpenLM will automatically upgrade the database to the new DB version.

At this stage we only support embedded Firebird installation. A release that supports external databases will be release soon.
If for any reason the process fails, send the report named FBDBUpdate_Log.txt located in unzipped file to our Support team at: support@openlm.com

OpenLM Maintenance release version 1.8.1.41

OpenLM Server version 1.8.1.41 – maintenance release

 

OpenLM Server version 1.8.1.41 is a maintenance release to version 1.8.

 

What’s new in OpenLM Server 1.8.1.41 (May 09, 2014)

 

[EasyAdmin] EasyAdmin stuck when clicking the crescent icon. – resolved.

[Server]: OpenLM Server error when running the cleanup tool – resolved

[Server]: 1.8 db upgrade issue – resolved

 

How to upgrade?

 

Backup your OpenLM Database and install the new version on-top of your existing version. This upgrade does not include a database upgrade, only software.

 

OpenLM New Pre-Release Version 2.0.0.3

OpenLM Pre-release version 2.0.0.3

Pre-release version 2.0.0.3 is the third pre-release version, it includes bug fixes and new functionality. Note that this is still a pre-release version not intended for production use, please don’t upgrade your production system.

 

Please check for upgrade instructions at the end of this message.

What’s new in OpenLM Pre-release Server 2.0.0.3 (April 24, 2014)

 

– 0001779: [OpenLM Server] exports xml instead off csv in license activity – resolved.

– 0001780: [EasyAdmin] License usage filter is not saved – resolved.

– 0001793: [EasyAdmin] can’t find the option to deprecate duplicates in the new alerts – resolved.

– 0001607: [OpenLM Server] support password in the dsls commands – resolved.

– 0001777: [EasyAdmin] Need to add startup filter to properties of recent feature denials – resolved.

– 0001771: [EasyAdmin] In files – should also show the option file – resolved.

– 0001770: [OpenLM Server] Logging level set to all does not change all sub-items – resolved.

– 0001767: [OpenLM Server] OpenLM Server does not report LUM Offline licenses correctly – resolved.

– 0001769: [OpenLM Server] Move VENDOR_STRING – resolved.

– 0001742: [OpenLM Server] Double quote username with spaces when writing option file – resolved.

– 0001737: [EasyAdmin] Column size not adjusted to size of contents in EasyAdmin – resolved.

– 0001751: [EasyAdmin] OpenLM splash screen need to be disabled when showing the login screen – resolved.

– 0001750: [EasyAdmin] When adding role you need to close the form in order to enable “add resources” – resolved.

– 0001753: [EasyAdmin] add username field by default to currently consumed licenses – resolved.

– 0001663: [OpenLM Server] Light: Light version is getting broker messages – resolved

 

How to upgrade

 

Upgrading from version 1.8.* using Firebird database

 

Upgrading an existing 1.8.* is done by installing the new version on-top of the existing version. OpenLM will automatically upgrade the database to the new DB version.

At this stage we only support embedded Firebird installation. A release that supports external databases will be release soon.

 

Upgrading from Pre-release version 2.0.0.0 or 2.0.0.1

 

Upgrade from version 2.0.0.0/1 is not supported. In order to install version 2.0.0.3 please follow these steps:

  1. Open the OpenLM Server configuration form->Advanced tab and export the system settings.

  2. Uninstall the existing OpenLM Server version.

  3. Fully remove the installation folder typically located in: C:\Program Files\OpenLM\OpenLM Server

  4. Install the new version of the software – 2.0.0.3

  5. Start the OpenLM Server configuration form->Advanced tab and import the file that contains your system settings.

 

Upgrading from Pre-release version 2.0.0.2 (Firebird database ONLY)

 

Upgrade from pre-release version 2.0.0.2 is done in two stages:

  • Software upgrade

  • Database upgrade

 

Software upgrade: Install the new version on top of the existing version.

  1. Starting from the Setup Wizard window, click Next

  2. Run this file window, click Run

  3. EULA Window, select I agree and click Next

  4. Installation window, click Next

  5. Confirm Installation window, click Next

  6. Pop-up window to install this software, click Next

  7. Installation complete, click Close

 

Database upgrade:

 

Download the DB upgrade tool is available for download from here.

 

OpenLM Database Wizard is released as compressed file. Copy and unzip the file to the desktop. Open the file marked FBUpdate.exe. This will open the OpenLM database Update Wizard

dbw1.JPG

 

Click the file button and locate the path where the database currently resides. Click Okay and then click Start>>

dbw2.JPG

 

The database has now been updated and the window can be closed.


If for any reason the process fails, send the report named FBDBUpdate_Log.txt located in unzipped file to our Support team at: support@openlm.com

OpenLM Broker Maintenance release version 1.8.2.5

OpenLM Broker version 1.8.2.5

 

OpenLM Broker version 1.8.2.5 is a maintenance release to version 1.8. It contains a bug fix to connecting the DSLS license manager. Users that need access the DSLS license manager using the broker should upgrade their version.

 

What’s new in OpenLM Server 1.8.2.5 (Apr 09, 2014)

 

– 0001679: [Config Tool] Broker command syntax for DSLS is not working – resolved.

OpenLM Maintenance release version 1.8.1.38

OpenLM Server version 1.8.1.38

OpenLM Server version 1.8.1.38 is a maintenance release to version 1.8. It is not a usual maintenance release since it’s only targeted to new installations. Existing users do not need to upgrade to this version.

The purpose of this version is to support UNICODE in new installations of OpenLM that use the embedded Firebird database.

What’s new in OpenLM Server 1.8.1.38 (Apr 09, 2014)

Support for UNICODE in OpenLM Firebird (embedded) database.

OpenLM New Pre-Release Version 2.0.0.2

OpenLM Pre-release version 2.0.0.2

Version 2.0.0.2 major change is that it fully supports unicode and by that allowing the user to use any language. It also contains few bug fixes listed below.We  recommend that users of previous 2.0 versions to whom these problems may be relevant to uninstall the 2.0.0.0 version and to install this version.

At this stage upgrade from version 2.0.0.0/1 is not supported. In order to install version 2.0.0.2 please follow these steps:

  1. Open the OpenLM Server configuration form->Advanced tab and export the system settings.

  2. Uninstall the existing OpenLM Server version.

  3. Fully remove the installation folder typically located in: C:\Program Files\OpenLM\OpenLM Server

  4. Install the new version of the software – 2.0.0.2

  5. Start the OpenLM Server configuration form->Advanced tab and import the file that contains your system settings.

What’s new in OpenLM Pri-release Server 2.0.0.2 (April 9, 2014)

– 0001756: [EasyAdmin] Message “get an openlm license file” is wrong – resolved.

– 0001754: [OpenLM Server] RLM – plugin error – resolved.

– 0001746: [OpenLM Server] error importing settings from 2.0 to 2.001 – resolved.

– 0001744: [OpenLM Server] EasyAdmin ist not showing Data für Servers containing an “&” in the name – resolved.

– 0001724: [EasyAdmin] option file admin – resolved.

OpenLM New Pre-Release Version 2.0.0.1

OpenLM Pre-release version 2.0.0.1

OpenLM Pre-release version was released about two weeks ago and based on feedback from our users we are releasing this second pre-release version. It contains some bug fixes to problems found in previous versions and enhancements. We  recommend that users of previous 2.0 versions to whom these problems may be relevant to uninstall the 2.0.0.0 version and to install this version.

At this stage upgrade from version 2.0.0.0 is not supported. In order to install version 2.0.0.1 please follow these steps:

  1. Open the OpenLM Server configuration form->Advanced tab and export the system settings.

  2. Uninstall the existing OpenLM Server version.

  3. Fully remove the installation folder typically located in: C:\Program Files\OpenLM\OpenLM Server

  4. Install the new version of the software – 2.0.0.1

  5. Start the OpenLM Server configuration form->Advanced tab and import the file that contains your system settings.

What’s new in OpenLM Pri-release Server 2.0.0.1 (April 7, 2014)

– 0001735: [OpenLM Server] Standard XML ignores multiple pools of specific license – resolved.

– 0001726: [OpenLM Server] In EA process/features window –> license release policy affects idle time reporting.  – resolved.

– 0001720: [EasyAdmin] System settings in the administration screen wording change – resolved.

– 0001583: [OpenLM Server] RMS expiration time reported incorrectly – resolved.

– 0001723: [EasyAdmin] don’t show fields – resolved.

– 0000967: [General] Enable SSL communication between modules – resolved.

– 0001529: [OpenLM Server] LM log must always be in ‘ALL’ mode – resolved.

– 0001229: [EasyAdmin] EasyAdmin shows compliance warning but audit report shows correct results – resolved.

– 0001647: [EasyAdmin] Audit Report should be consistent with Compliance Warning in Easy Admin – resolved.

– 0001621: [EasyAdmin] Denials: tab name – resolved.

OpenLM Maintenance release version 1.8.1.36

OpenLM Server version 1.8.1.36

OpenLM Server version 1.8.1.36 is a maintenance release to version 1.8. It contains some bug fixes to problems found in previous versions and enhancements. We  recommend that users of previous 1.8 versions to whom these problems may be relevant upgrade their system to this version.

Upgrading the OpenLM Server

In order to upgrade to version 1.8.1.36:

1. Stop the OpenLM Server service

2. Backup your DB file (Typically located in: C:\Program Files\OpenLM\OpenLM Server\db)

3. Make sure ALL windows are closed; especially the services window.

4. Install the new version on top of the existing one.

5. If prompted to do so, contact OpenLM to obtain an up-to-date license file. Please provide your MAC address and Hostname (case sensitive) for that. Copy this file to the

C:\Program Files\OpenLM\OpenLM Server\License   folder, and restart the OpenLM Server service.

What’s new in OpenLM Server 1.8.1.36 (Apr 01, 2014)

1. Issue  #1385: [EasyAdmin] Cant select colors from palette in License Usage window

2. Issue  #1731: [OpenLM Server] MS-SQL DB upgrade 1.7 –> 1.8 failed

3. Issue  #1732: [OpenLM Server] Can’t see all licenses when reading license file.

4. Issue  #1734: [OpenLM Server] LDAP – Unknown schemaClassNames