OpenLM Maintenance Release Version 1.8.1.4

OpenLM Server version 1.8.1.4

OpenLM Server version 1.8.1.4 is a maintenance release to version 1.8. It contains some bug fixes to problems found in previous versions. We  recommend that users of previous 1.8 versions to whom these problems may be relevant upgrade their test system to this version.

Upgrading the OpenLM Server

From version 1.8 beta:

In order to upgrade to version 1.8.1.4:

1. Uninstall the OpenLM 1.8 beta version

2. Delete the OpenLM Server folder, Typically located in:

C:\Program Files\OpenLM\OpenLM Server\

3. Install the OpenLM server 1.8.1.4 version.

4. If prompted to do so, contact OpenLM to obtain an up-to-date license file. Please provide your MAC address and Hostname (case sensitive) for that. Copy this file to the

C:\Program Files\OpenLM\OpenLM Server\License   folder, and restart the OpenLM Server service.

From versions 1.7 and 1.8:

At this stage we do not recommend upgrading OpenLM production systems to version 1.8. This version is relevant to the upgrade of previous 1.7 & 1.8 test systems.

In order to upgrade to version 1.8.1.4:

1. Stop the OpenLM Server service

2. Backup your DB file (Typically located in: C:\Program Files\OpenLM\OpenLM Server\db)

3. Make sure ALL windows are closed; especially the services window.

4. Install the new version on top of the existing one.

5. If prompted to do so, contact OpenLM to obtain an up-to-date license file. Please provide your MAC address and Hostname (case sensitive) for that. Copy this file to the

C:\Program Files\OpenLM\OpenLM Server\License   folder, and restart the OpenLM Server service.

 

What was fixed in OpenLM Server version 1.8.1.4 (and its close predecessors)?

Version 1.8.1.2 (Published 18.04.2013)

1. LDAP Group synchronization issue

2. Fix configuration settings exception.

3. Fix License Usage information. Thank you Robert Mercier.

4. Easyadmin – OpenLM Server up time update.

Version 1.8.1.3 (Published 25.04.2013)

1. Ldap performance improvements

2. Bug #743- missing apply button in configuration.

3. Bug #750 – migrate groups from  OpenLM version 1.7 .

4. Bug #756 – LDAP synchronization window in Easy Admin always shows “Set Default Group” marked regardless what is configured

5. Bug #759 – tests page.

6. Bug #757 – The system report very high number of users, more than it make sense.

7. Bug #592 – groups preview – enable only when relevant.

8. Procurements’ table handling improvements.

9. Bug #766 – “used” hyperlink from “licenses” window did not filter by feature.

10. Bug #768 – Sorting by server column in “License Procurement” window

11. Bug #761: Export from “License Activity” report does not include all columns.

12. Bug 734: csv Export from “License Procurement” has xml content not csv.

13. RMS issue: usage data is skipped when status line doesn’t include a proper date value.

14. Supporting selection of multiple expiration items, fix for alerts system.

15. Bug 769 – new feature description lut link to license inventory.

16. Help button is removed from option file windows.

Version 1.8.1.4 (Published 02/05/2013)

1. Fix DSLS command check in configuration form.

2. Bug #709: host availability graphics issues.

3. Bug #748: “Split screen” problem.

4. Bug #783: Host availability – chart lines are not the same color as the legend.

5. Bug #488 – Alerts not arriving from LUM servers on threshold queries. No unique result.

6. Bug #781 – Fixed handling of LDAP loops

7. Fixed “CloseApplication” , “RemoveLicense” requests malfunction.

OpenLM Broker version 1.8.1.3

OpenLM Broker version 1.8.1.3 is a maintenance release to version 1.8. It contains some bug fixes to problems found in previous versions. We  recommend that users of previous 1.8 versions to whom these problems may be relevant upgrade their system to this version.

Upgrading the OpenLM Broker

Upgrading the OpenLM Broker is quite straightforward. One item is left for the installer to decide:

  • If a previous 1.8 Broker version exists on this machine, the 1.8.1.3 Broker would simply replace it.

  • If only a previous 1.7 Broker version exists on this machine, the installation would prompt the user  to choose whether to replace it or to install it side-by-side with the 1.7 version. This is for supporting both a production 1.7 version and a test 1.8 version.

What was fixed in OpenLM Broker version 1.8.1.3 ?

1. Bug #729 – 3 messages when clicking “check connectivity”.

2. Bug #752 –  remove RMS default path.

3. Fixed failure to update option file.

4. Installation support upgrade for 1.8 Side By Side.

What was fixed in OpenLM Agent versions 1.8.1.2 and 1.8.1.1 ?

Version 1.8.1.1 (Published 18.04.2013)

Fixed High cpu consumption bug.

Version 1.8.1.2  (Published 02.05.2013)

1. Bug #739 – feature name missing from license usage grid.

2. Bug #719 – When two software applications are closed on the same workstation – messages are referring to the wrong application.

3. Bugs #721,727 manual closure of ArcGIS; closes only one session while the license remains occupied.

 

 

Please follow and like us: