OpenLM New Pre-Release Version 2.0.0.4

OpenLM Pre-release version 2.0.0.4

Pre-release version 2.0.0.4 is the forth pre-release version, it includes bug fixes and new functionality. Note that this is still a pre-release version not intended for production use, please don’t upgrade your production system.

Please check for upgrade instructions at the end of this message.

What’s new in OpenLM Pre-release Server 2.0.0.4 (May 8, 2014)

– 0001830: [OpenLM Server] RMS Parsing does not work as expected in 2.0.0.3 version – resolved.

– 0001815: [EasyAdmin] Browser hangs when opening “Quantity” on “License Servers” fast – resolved.

– 0001813: [EasyAdmin] user setting wizard text needs a change – resolved.

– 0001796: [EasyAdmin] Notification window links should open in a new tab – resolved.

– 0001789: [OpenLM Server] Project prompt shows even if there is no license in use by the user – resolved.

– 0001801: [EasyAdmin] When removing unmanaged license server the currently consumed licenses are not deleted – resolved.

– 0001814: [EasyAdmin] filter text need to change – resolved.

– 0001785: [EasyAdmin] Deleting from unmanaged preceses does not refresh the form  – resolved.

– 0001794: [EasyAdmin] when loading a filter all filter sections opens even if empty which is very annoying – resolved.

– 0001752: [EasyAdmin] status date format – resolved.

– 0001762: [EasyAdmin] Date/Time format in Alerts window wrong – resolved.

– 0001682: [EasyAdmin] License Usage – When timezone is not defined the chart window hungup – resolved.

– 0001812: [OpenLM Server] License usage – use also current sessions (not only historic) – resolved.

– 0001781: [EasyAdmin] close application should not show for unmanaged licenses – resolved.

– 0001765: [EasyAdmin] Improve the message bar in EasyAdmin forms – resolved.

– 0001802: [EasyAdmin] Clicking on the currently consumed license in the license server list fetch wrong filter – resolved.

How to upgrade

Upgrading from version 1.8.* using Firebird database

Upgrading an existing 1.8.* is done by installing the new version on-top of the existing version. OpenLM will automatically upgrade the database to the new DB version.

At this stage we only support embedded Firebird installation. A release that supports external databases will be release soon.

Upgrading from Pre-release version 2.0.0.0 or 2.0.0.1

Upgrade from version 2.0.0.0/1 is not supported. In order to install version 2.0.0.4 please follow these steps:

  1. Open the OpenLM Server configuration form->Advanced tab and export the system settings.
  2. Uninstall the existing OpenLM Server version.
  3. Fully remove the installation folder typically located in: C:\Program Files\OpenLM\OpenLM Server
  4. Install the new version of the software – 2.0.0.4
  5. Start the OpenLM Server configuration form->Advanced tab and import the file that contains your system settings.

Upgrading from Pre-release version 2.0.0.2 and 2.0.0.3 (Firebird database ONLY)

Upgrade from pre-release version 2.0.0.2 and 2.0.0.3 is done in two stages:

  • Software upgrade
  • Database upgrade

Software upgrade: Install the new version on top of the existing version.

  1. Starting from the Setup Wizard window, click Next
  2. Run this file window, click Run
  3. EULA Window, select I agree  and click Next
  4. Installation window, click Next
  5. Confirm Installation window, click Next
  6. Pop-up window to install this software, click Next
  7. Installation complete, click Close

Database upgrade (Needed only when upgrading from version 2.0.0.2):

Download the DB upgrade tool is available for download from here.

Note: Database upgrade is not needed when upgrading from version 2.0.0.3. If you are upgrading from this version check the upgrade instruction as detailed in this post.

If for any reason the process fails, send the report named FBDBUpdate_Log.txt located in unzipped file to our Support team at: support@openlm.com