Trouble Shoot Form: EasyAdmin Item 001 (Unable to connect to EasyAdmin)

Title Unable to connect to EasyAdmin
Category EasyAdmin web application
Date Oct 11, 2011
Handled by
Relevant Links
Applies to license managers FLEXlm, FLEXnet, IBM LUM, HASP, RLM, Sentinel RMS
Applies to license model Floating licenses, Network licenses, Concurrent licenses
Symptoms Customer could not connect to EasyAdmin.
Observed during investigation
Trouble shoot process Check web server service running,
Check OpenLM server service running.
Solution Found (Found/Pending/Known Issue)
Other steps for troubleshooting

Symptom

The customer complained that he “Couldn’t connect to the EasyAdmin”. Attempting to open the EasyAdmin web application resulted in the following message box appearing on his screen:

In a similar case, the customer got a different notification:

 Troubleshoot process

This kind of issues is related to services that have stopped and are not currently active. The 1st thing to try is restarting the respective process.

1. Navigate to the windows services: Click Start → Control Panel → System and Security → Administrative Tools → Services. The “Services” window appears.

2. In the first case (“Couldn’t connect to host” message box), it may be an issue of the OpenLM Server service.

2a. Select that OpenLM Server service in the “Services” window.

2b. Right click the OpenLM Server service, and set it to restart – see image below.

2c. Restart the EasyAdmin web application.

3. If the 2nd type message box (“Please Check your Internet connection”) appeared, it may be an issue of the web server service. Restart your web server service (e.g.: LightTPD).

Other steps for troubleshooting:

If restarting the services does not work – here are some other things you may try:

  • Run the EasyAdmin application from the same computer as the OpenLM Server.

  • Make sure that any security components (Firewall) are not blocking communication to the EasyAdmin web application.

  • Temporarily stop the OpenLM Server and OpenLM Broker services. Open the task manager’s processes window. Make sure the computer is not held-up by any other process.

  • Still in the task manager’s processes window, look for the LightTpd process. If there are multiple processes with that name – kill them, and restart the LightTpd service on the services window.

  • Make sure the default HTTP listener port (7019) is kept open. Try a different port (e.g. 7020) on the lighttpd-inc.conf configuration file(C:\Program Files\OpenLM\OpenLM Server\WebServer) . Then restart LightTPD service.

  • Try connecting the proxy to the test page; Select the test page from the ‘Start’ menu (see below). Click the ‘Check’ button. An indication similar to that of the 2nd image below should appear.

  • Try a different web browser.

  • Try erasing the Proxy server logs. These are found in the following positions:

Win 7: C:\ProgramData\OpenLM

XP, Win 2003: C:\Documents and Settings\All Users\Application\OpenLM

Please follow and like us:

Trouble Shoot Form: Broker Item 003 (LUM licenses don’t show up in EasyAdmin)

 

Title LUM licenses don’t show up in EasyAdmin
Category Broker
Date Nov 11, 2011
Handled by
Relevant Links http://bug.openlm.com/view.php?id=225
Applies to license managers LUM
Applies to license model Floating licenses, Network licenses, Concurrent licenses, Node Locked
Symptoms LUM licenses don’t show up in EasyAdmin.
Observed during dubug 1. The Broker was not sending any information to the OpenLM Server
2. The Broker “test connectivity” button clicked: Broker saw the OpenLM Server OK.
Trouble shoot process 1. Upgraded Broker version.
2. Changed the I4BLT.EXE path from the OpenLM folder to one supplied by the application vendor.
Solution Found (Found/Pending/Known Issue)

Symptom

LUM licenses don’t show up in EasyAdmin.

Solution

1. Upgrade the OpenLM Broker on the license server machine. Refer to the Application Note for reference.
2. As part of the OpenLM package, the latest version of the I4BLT.EXE file is supplied. This file may not be inter-operable (version too new) with the licensed application version. If this is the case, please follow these steps:

Changing a single port’s configuration

  1. Open the OpenLM Broker configuration tool.
  2. Select the relevant License server.
  3. Check the “Update to the following path” radio button
  4. Click the “Edit” button. The text box becomes active.
  5. In the “Path” text box, type in the path of the I4BLT.EXE file in the LUM folder, originally supplied by the application vendor.

This configuration change may also be achieved by individually typing the I4BLT.EXE file path in each Broker command text box.

Changing all ports’ configurations

  1. Open the OpenLM Broker configuration tool.
  2. Click the “Advanced Settings” wrench icon. The Advanced settings window opens.
  1. Click the “Edit” button. The text boxes become active.
  2. In the “I4BLT Path” text box, type in the path of the I4BLT.EXE file in the LUM folder, originally supplied by the application vendor.
  1. Select a specific port’s “Commands” list item. The “Commands” window opens.
  1. Check the “Update according to advanced settings” radio button, and click the “Update” button. The I4BLT path of the specific port is changed.
  2. Repeat steps 5 & 6 for all ports.
Please follow and like us:

Trouble Shoot Form: OpenLM Server Item 001(Unable to upgrade OpenLM server version)

 

Title Unable to upgrade OpenLM server version
Category Installation
Date Nov 03, 2011
Handled by Rachel, Oren
Relevant Links
Applies to license managers FLEXlm, FLEXera FLEXnet, IBM LUM, HASP, RLM, Sentinel RMS
Applies to license model Floating licenses, Network licenses, Concurrent licenses, Node Locked
Symptoms “After upgrade, server configuration will not run”
Customer could not uninstall The OpenLM Server module, due to lacking permissions.
Observed during investigation Customer could not uninstall The OpenLM Server module.
OpenLM Server Service was not uninstalled.
Trouble shoot process Uninstall and reinstall the OpenLM Server Service manually.
Solution Found (Found/Pending/Known Issue)

Symptom

The customer complained that after upgrading the OpenLM server, the server configuration form would not open.

Observed during investigation

The customer could not uninstall the OpenLM server module. Although being set as an administrator with administrative privileges, he was denied the ability to uninstall the OpenLM server service.

Solution

1. Back up the Database.
2. Uninstall the OpenLM server service, using a CMD file:

  • Compile a CMD file (e.g.: myUninstallFile.cmd) from the following code.
  • Run the CMD file as an administrator: Either from a command line, or Right-click on its icon, and choose to run it as an administrator.

// Stop the OpenLM Server service
net stop “OpenLM Server”
// Uninstall the OpenLM Server Service
“C:\Windows\Microsoft.NET\Framework\v4.0.30319\installutil.exe” /u “C:\Program Files\OpenLM\OpenLM Server\bin\OpenLM_Server.exe”
// Wait for the user to click any key
pause

3. Uninstall the OpenLM Server Using the Windows Control Panel.

Note: The OpenLM server service may be reinstalled using a CMD file in a similar manner to that of the uninstallment process:

  • Compile a CMD file (e.g.: myReinstallFile.cmd) from the following code.
  • Run the CMD file as an administrator: Either from a command line, or Right-click on its icon, and choose to run it as an administrator.

// Reinstall the OpenLM Server Service
“C:\Windows\Microsoft.NET\Framework\v4.0.30319\installutil.exe” “C:\Program Files\OpenLM\OpenLM Server\bin\OpenLM_Server.exe”
// Wait for the user to click any key
pause

4. Restart the OpenLM server service.

5. Download and run the latest OpenLM server version (MSI file)

Please follow and like us:

Trouble Shoot Form: OpenLM Server Item 002 (Connection to FlexLM license server failed)

Title Unable to connect to FlexLM license server
Category OpenLM Configuration Form
Date Nov 03, 2011
Handled by
Relevant Links
Applies to license managers FLEXlm, FLEXnet publisher
Applies to license model Floating licenses, Network licenses, Concurrent licenses, Node Locked
Symptoms No activity reported on EasyAdmin for a specific FlexLM license server
Observed during investigation A License server’s  ‘LED’ on the EasyAdmin “License Servers” window is red.
Clicking the “Check” button for one of the license servers on the OpenLM Configuration Form resulted in an error.
Trouble shoot process Check License server connectivity configuration.
Solution Found (Found/Pending/Known Issue)

Symptom

The customer complained that there was no activity on the EasyAdmin web application regarding a specific license server.

Solution

1. Make sure the License server configuration is correct:

  • Open the LMtools utility on the “Server status” tab.
  • Click the “Perform status Enquiry”. Status text appears.
  • On the “License server status” line – extract the Server name and status (e.g.: olm_lm_acad and 27000)

2. Install the OpenLM Broker on each license server machine. Refer to the Application Note for reference.

Please follow and like us: